Library requirements for Flash 9 Player for Linux

As we draw closer to an anticipated beta release of the Flash Player, we thought people might be interested in knowing what libraries their host systems will be expected to provide for the Player. We have boiled it down to this list:

* libdl.so.2
* libpthread.so.0
* libX11.so.6
* libXext.so.6
* libXt.so.6
* libfreetype.so.6
* libfontconfig.so.1
* libgtk-x11-2.0.so.0
* libgobject-2.0.so.0
* libglib-2.0.so.0
* libm.so.6
* libc.so.6

If the library loader cannot find any of the above libraries then the plugin will refuse to load and the user will continue to see the dreaded green puzzle piece in place of a bouncing animation.

http://blogs.adobe.com/penguin.swf/2006/09/librarian.html

Topic: